개요

latex 관련 문서나 자료는 Comprehensive TEX Archive Network(CTAN)에서 구할 수 있다.

http://www.ktug.or.kr

설치해야 할 소프트웨어 목록은 다음과 같다.

  1. MiKTeX
    ftp://ftp.ktug.or.kr/pub/ktug/miktex/
  2. GhostScript
    ftp://ftp.ktug.or.kr/pub/mirrors/ghost/AFPL/
  3. GSView(PostScript Previewer)
    ftp://ftp.ktug.or.kr/pub/mirrors/ghost/ghostgum/
  4. ImageMagick
    ftp://ftp.ktug.or.kr/pub/mirrors/ImageMagick/
  5. Perl
    http://www.activestate.com
  6. NetPBM
    http://sourceforge.net/projects/netpbm
  7. LaTeX2HTML
    http://www.latex2html.org/


설치하기

설치가 끝나면 시스템 환경 변수인 PATH에 각 소프트웨어의 bin 폴더의 경로를 추가한다.

  • MiKTeX 설치하기
  • Ghostscript 설치하기
  • GSView 설치하기
  • Perl 설치하기
  • NetPBM 설치하기
  • LaTeX2HTML 설치하기


MiKTeX 설치하기

다음 주소에서 설치 파일을 내려받는다.

ftp://ftp.ktug.or.kr/pub/ktug/miktex/

설치 방법은 버전에 관계없이 모두 동일하다.

setup-ktug.exe를 실행시킨다.

  1. 을 누른다.

  2. 을 선택하고 [image] 을 누른다.

  3. 여기서의 작업은 패키지를 내려받는 것이고, 실제 설치할 패키지를 선택하는 것은 다운로드가 끝난 후이므로, 이후 다른 패키지가 필요할 경우를 대비해 [image] 를 선택하고 [image] 을 누른다.

    최소
    가장 기본적인 패키지만을 설치한다. 내려받을 파일의 크기는 약 23 MB이고, 컴퓨터에 설치된 후 압축이 풀린 상태에서는 약 100 MB의 공간을 필요로 한다.
    보통
    내려받을 파일의 크기는 약 64 MB이고, 컴퓨터에 설치된 후 압축이 풀린 상태에서는 약 200 MB의 공간을 필요로 한다.
    전체
    내려받을 파일의 크기는 약 143 MB이고, 컴퓨터에 설치된 후 압축이 풀린 상태에서는 약 500 MB의 공간을 필요로 한다.

  4. 패키지를 제공하는 사이트를 선택하고 [image] 을 누른다.

  5. 내려받을 파일을 저장할 디렉토리를 지정하고 [image] 을 누른다.

  6. 이제까지 설정한 내용을 확인하고 [image] 을 눌러 내려받기를 시작한다.

  7. 내려받기가 끝나면 setup-ktug.exe를 다시 실행시켜 내려받은 파일들을 설치한다.

  8. 을 선택하고 [image] 을 누른다.

  9. 내려받을 파일들을 저장한 디렉토리를 지정하고 [image] 을 누른다.

  10. 설치할 디렉토리를 지정하고 [image] 을 누른다.

  11. 프로그램 폴더의 이름을 지정하고 [image] 을 누른다.

  12. 을 선택하고 [image] 을 누른다.

  13. 을 선택하고 [image] 을 누른다.

  14. 이제까지 설정한 내용을 확인하고 [image] 을 눌러 설치를 시작한다.


 next up previous
다음: GSView 설치하기 위로: 설치하기 이전: MiKTeX 설치하기

Ghostscript 설치하기

다음 주소에서 내려받는다.


GSView 설치하기

다음 주소에서 내려받는다.

http://ftp.ktug.or.kr/mirrors/ghost/ghostgum/


 next up previous
다음: NetPBM 설치하기 위로: 설치하기 이전: GSView 설치하기

Perl 설치하기

다음 주소에서 내려받는다.

http://www.activestate.com


NetPBM 설치하기

다음 주소에서 내려받는다.

http://sourceforge.net/projects/netpbm


LaTeX2HTML 설치하기

다음 주소에서 내려받는다.

http://www.latex2html.org/

  1. 임시 폴더에 압축을 푼다.

    1. config.pl을 다음과 같이 수정한다.
      @tryopts = ('','--version','-?','-v'); -> @tryopts = ('-v');
    2. prefs.pm에 설치 경로를 기재한다.
      $prefs{'PREFIX'} = 'C:\\...\\latex2html';
    3. latin1.pl을 다음과 같이 수정한다.
      $CHARSET = "EUC-KR";

  2. config.bat을 실행한다. 그러면 install.bat이 만들어진다.
  3. install.bat을 실행한다. 그러면 test.bat이 만들어진다.
  4. test.bat을 실행한다. tests\l2htest\index.html이 제대로 만들어졌는지 확인한다.
  5. install.bat을 실행한다.
  6. latex2html.bat에서
    $LATEX2HTMLSTYLES=~s/~([^$dd$dd$envkey]+)/L2hos->home($1)/geo;
    를 주석처리한다.
  7. texmf\miktex\config\miktex.ini를 다음과 같이 수정한다
    GraphicsPath=.;..;%R\dvips//;%R\tex//
  8. \latex2html\texinputs를 MiKTeX의 옵션관리자에서 texmf 폴더 군에 추가한다.
  9. l2hconf.pm을 원하는 대로 수정한다.


install

 next up previous
다음: 개요

  • 개요
  • 설치하기
    • MiKTeX 설치하기
    • Ghostscript 설치하기
    • GSView 설치하기
    • Perl 설치하기
    • NetPBM 설치하기
    • LaTeX2HTML 설치하기